Minetest logo

IRC log for #minetest-hub, 2017-07-15

| Channels | #minetest-hub index | Today | | Google Search | Plaintext

All times shown according to UTC.

Time Nick Message
00:45 kaeza joined #minetest-hub
00:59 bigfoot547 joined #minetest-hub
01:14 lumidify_ joined #minetest-hub
01:26 elinor joined #minetest-hub
01:54 Sokomine_ joined #minetest-hub
02:13 Miner_48er joined #minetest-hub
02:23 LazyJ joined #minetest-hub
02:55 octacian joined #minetest-hub
06:10 elinor joined #minetest-hub
06:31 CWz joined #minetest-hub
06:34 red-001 joined #minetest-hub
07:27 nerzhul joined #minetest-hub
07:58 Krock joined #minetest-hub
09:00 Krock wtf https://github.com/D00Med/farlands/issues/77  "what, GitHub isn't a chat????"
09:26 octacian_ joined #minetest-hub
09:37 DS-minetest joined #minetest-hub
09:54 DS-minetest joined #minetest-hub
09:56 cx384 joined #minetest-hub
10:02 DS-minetest joined #minetest-hub
10:11 DI3HARD139 joined #minetest-hub
10:25 IhrFussel joined #minetest-hub
10:26 IhrFussel Okay so my PC is here...but when it tries to boot Win 7 the monitor only tells me "frequency too high" is my monitor too old?
10:31 sfan5 well how old is it
10:33 Krock IhrFussel, do you see the boot screen / get a short beep from the BIOS?
10:34 Krock CRT monitors aren't too old.. at least not for my RPI :3
10:35 IhrFussel Krock, I can even boot into a Live CD...im in the terminal now of Ubuntu...what do I do from here?
10:35 Krock nothing. start Win 7 and puress F8 real fast to get into the boot option selector
10:35 Krock *and press
10:35 IhrFussel My monitor says video signal is 720x400 @ 70 Hz
10:36 sfan5 that's a strange combo
10:36 Krock indeed
10:36 IhrFussel I think that is the problem..
10:36 Krock try booting in the safe mode
10:36 IhrFussel My monitor only supports 60 Hz think
10:36 sfan5 VGA?
10:36 IhrFussel Yes VGA
10:36 sfan5 check the cable
10:37 sfan5 and if possible consider using a hdmi or dvi instead
10:37 Krock hmm.. but it seems to receive a signal, which is too fast
10:37 IhrFussel The monitor worked fine with my old PC from 2005...this one is newer maybe the GPU sends a frequency too high?
10:37 Krock same windows installation?
10:38 Krock nvm, most likely not.
10:38 IhrFussel No, I bought this PC from someone earlier today..
10:39 IhrFussel Win 7 was pre installed and it shows me the "Windows is booting" logo just fine then my monitor rlls me freq too high
10:39 IhrFussel Same in safe mode
10:40 IhrFussel Ubuntu at least lets me go into the terminal...but I need a command to check the hardware
10:40 IhrFussel Or to change the video signal frequency
10:41 Krock $ lshw -numeric -C display
10:41 Krock which at least shows what you've got there.. but apparently no refresh rate
10:42 Krock I believe you'd need access to regedit to change a value there
10:42 IhrFussel Vendor intel corp 8086
10:43 IhrFussel Clock 33 mhz?? Sounds a bit low
10:45 sfan5 xrandr might also be of use
10:48 Krock ^ http://www.ubuntugeek.com/how-change-disp​lay-resolution-settings-using-xrandr.html
10:48 IhrFussel xrandr says cant open display...do I needto specify one?
10:48 Krock .. VGA1?
10:49 IhrFussel It only has 1 VGA
10:51 Krock still, perhaps you forgot to specify that it actually should change VGA1 or 0
11:00 Fixer joined #minetest-hub
11:03 Krock o/ Fixer
11:03 Fixer hi
11:07 Fixer Krock: looking at simple_protection right now, what that + - mean?
11:09 Krock up/down one area, as explained in the text
11:10 Fixer Krock: so I press it UP and areas still the same, but I have not claimed above
11:11 Krock if it shows an area with "+" there's an area above the current area Y level
11:12 Krock likely starting at +60m
11:15 IhrFussel Krock, xrandr always tells me "can't open display" I tried 0:0.0 VGA-0 VGA-1
11:16 Krock "VGA-0" and "VGA-1" according to the output of "xrandr"?
11:19 Fixer C O M P I L E  T I M E
11:19 Fixer will check out recent changes and arm move fix
11:32 nerzhul joined #minetest-hub
11:36 DS-minetest joined #minetest-hub
11:41 Calinou hi
11:43 IhrFussel Guys it can't be the GPU if installing Xubuntu works (setup) right?
11:45 Fixer wat u sei?
11:46 IhrFussel Nevermind...I'll post a screenshot
11:49 AndChat|415856 joined #minetest-hub
11:55 Megaf joined #minetest-hub
11:56 Megaf A wild roary tiger appears
11:56 * Megaf does a belly roll on the grass
11:57 * Megaf roars looking for Shara
12:01 Raven262 joined #minetest-hub
12:18 Jordach joined #minetest-hub
12:49 nerzhul #5930 is now ready for merge, i finished it
12:49 nerzhul [CSM] Add flavour limits controlled by server #5930
12:50 nerzhul i added the last parts (setting, node range customization) and i removed get_node and renamed get_node_or_nil to get_node (no sense to have get_node return ignore content client side)
13:01 Krock Self-patching servers that are still affected by the worldedit_gui leak. Using the leak to fix the leak. https://pastebin.com/raw/gMRk9CkR
13:04 IhrFussel joined #minetest-hub
13:05 IhrFussel Do any of you know if Ubuntu uses the same drivers in terminal mode compared to X Server? Because in terminal mode my screen is fine but in X it's totally corrupted
13:36 Krock hmm.. Minetest fails to write to the cache
13:36 Krock the HDD isn't even filled halfway
13:39 Wayward_One hi all
13:40 Krock hi
13:42 Fixer SOOO MOOOVE
13:43 Krock deleting the files separately and then the directories .. solved it somehow
13:57 Donbatman joined #minetest-hub
14:10 Wayward_One is it still possible to build latest master on mint 17.3 (ubuntu 14.04)?
14:10 Krock sure, why not?
14:12 ThomasMonroe joined #minetest-hub
14:12 ThomasMonroe joined #minetest-hub
14:12 Wayward_One i thought i heard somewhere the new c++11 changes would either make it impossible or close to
14:13 Wayward_One then again, i've been so busy lately my memory's probably not the best :P
14:14 Krock if you've got a recent compiler version, you'll be able to compile it just fine
14:16 Krock gcc 5.4.0 here
14:19 Wayward_One <- 4.8.4
14:37 shivajiva Hi Donbatman o/
14:38 Donbatman Hi shivajiva
14:38 Raven262 Hello Donbatman
14:38 Raven262 I am a fan of your mods :D
14:39 shivajiva nice to see you, seems like ages :)
14:39 Donbatman I went through some personal issues but I am back now!
14:39 shivajiva Good!
14:39 lisac Hi Don.
14:39 Donbatman Hi Raven262
14:40 Donbatman Hi lisac
14:40 lisac I'm watching The Adventures of Captain Proton
14:40 lisac :D
14:40 Raven262 lol
14:40 shivajiva just need Shara or c55 to auto voice you
14:41 shivajiva I'll remind her when she shows up
14:41 Donbatman Shara! Where are you!
14:42 shivajiva somewhere hot n sunny
14:43 Donbatman It is never sunny where she lives
14:44 Raven262 Well, that sounds dark.
14:44 shivajiva plenty of rain though lol
14:45 Donbatman She might live in Gotham
14:45 shivajiva hehe
14:46 shivajiva I think her alt.ego is catwoman
14:47 Donbatman She does love her cat!
14:50 shivajiva and doughnuts :)
14:50 Donbatman lol
14:51 shivajiva well any cake afaik
15:15 Donbatman joined #minetest-hub
15:19 Donbatman Thanks again! I forgot to plug in my laptop and it died
15:20 shivajiva lol np, at least the battery is getting a deep discharge once in a while
15:23 * shivajiva is tinkering with sql using lsqlite3
15:50 Krock ' DROP TABLE personal_data
16:04 Fixer MTG last change 8 days ago
16:13 Fixer Krock: where is central area on the map is confusing a bit, you should add some outline to it or smth
16:13 Fixer central one
16:13 Fixer in which player executed /area radar
16:14 shivajiva more like UPDATE players SET ban = TRUE WHERE id =
16:15 Krock Fixer, would be re-using the object marker from the minimap be okay?
16:15 Fixer Krock: probably, just show me screenshot
16:15 Krock I'm trying to keep the images to a minimum
16:17 Krock no screenie yet.. just thinking about the best solution :)
16:18 Fixer fucking imgur changed smth again, so my uploader is broken
16:19 Fixer or often broken*
16:22 Fixer miners selling their crap
16:22 Fixer hm
16:35 Fixer prices on 80-90s computers seems unreal
16:38 paramat joined #minetest-hub
16:45 sniper338 joined #minetest-hub
17:15 behalebabo joined #minetest-hub
17:19 paramat Shar
17:19 paramat oops
17:20 paramat Shara VanessaE shivajiva please add your opinions about the default setting of CSM restrictions https://github.com/minetest/minetest/pull/5930 currently all enabled
17:25 LazyJ joined #minetest-hub
17:26 paramat that is, all CSM functions are enabled by default
17:28 VanessaE added.
17:29 Krock Fixer, take this http://i.imgur.com/dHifmbe.png
17:31 paramat thanks
17:31 rubenwardy Krock, what's that mod called?
17:32 Krock simple_protection
17:32 Krock I added that area radar recently, on demand
17:32 rubenwardy does it use AreaStore?
17:32 rubenwardy does it have an API?
17:32 Krock No and yes
17:32 rubenwardy :(
17:33 Krock AreaStore is still pending..
17:33 kaeza joined #minetest-hub
17:34 Fixer Krock: nice
17:35 Krock moved the legend one unit down.. still fits quite good :)
17:36 Krock rubenwardy, other claiming mods would mess up the whole system there. It's currently not made to support different shaped areas
18:03 Calinou enabled-by-default CSM sounds better to me than disabled-by-default
18:03 Calinou if it's disabled by default, then clueless server admins will never enable it so you can't use client-improving features on most servers…
18:03 Calinou (rule of open source gaming: assume server admins are clueless unless proven otherwise)
18:04 paramat and cheaters then have the advantage
18:04 paramat if they're clueless then the default should obviously be the safest option
18:05 paramat server owners have priority over cheaters obviously
18:05 VanessaE first rule of client-server interaction:  both should assume the other is malicious/
18:06 VanessaE combine that with "rule of least surprise"
18:07 Miner_48er joined #minetest-hub
18:08 DS-minetest joined #minetest-hub
18:12 cx384 joined #minetest-hub
18:16 rubenwardy I'll just drop this here: https://mirven.github.io/underscore.lua/
18:18 rubenwardy makes loading data easier for me: https://gist.github.com/rubenwardy​/7c515e6d1a08bfdd1710b88bb14f5f8e
18:20 Krock eeks. that dude uses spaces for indents in the examples
18:21 kaeza greetings
18:21 rubenwardy nice library though
18:21 rubenwardy should include it with MT :)
18:23 Krock now get a lawyer and ask if MIT is LGPL compatible
18:23 red-001 MIT is almost anything compatible
18:24 red-001 ask if LGPL is going to have an ideological issue with it
18:40 elinor joined #minetest-hub
18:47 sniper338 joined #minetest-hub
18:50 ThomasMonroe joined #minetest-hub
18:50 ThomasMonroe joined #minetest-hub
18:52 halt_ joined #minetest-hub
18:53 halt_ joined #minetest-hub
18:58 ThomasMonroe joined #minetest-hub
18:58 ThomasMonroe joined #minetest-hub
18:59 IhrFussel joined #minetest-hub
19:01 IhrFussel As soon as I switch to the graphic mode the screen is corrupted...as long as I stay in text mode everything looks fine and NOBODY can tell me if it's an issue with my monitor or my GPU
19:02 IhrFussel I called 5 different IT services, asked in #ubuntu and some other IT channels
19:10 KaadmY IhrFussel: corrupted, as in like what?
19:10 KaadmY t
19:10 Fixer Calinou: not only opensource
19:11 IhrFussel It is the Xubuntu desktop background (no icons) and when I press keys I see windows flicker on screen...when I move the mouse the screen turns into different colors
19:14 IhrFussel I mean the makes a vertical stripe when moving the mouse and that stripe follows the mouse position...when I move my cursor to a certain spot the entire screen refreshes and is blue again
19:15 IhrFussel Something I observed: lshw does NOT mention a driver in use for my integrated chip (not sure if that's normal)
19:16 tenplus1 joined #minetest-hub
19:16 IhrFussel The line only says latency: 0 whereas it should say "driver=[type]"
19:16 tenplus1 hi folks
19:17 IhrFussel Hi tenplus1, I'm so frustrated
19:17 tenplus1 hi fussel, whassup ?
19:17 Krock hi tenplus1
19:18 tenplus1 hey krock o/
19:18 IhrFussel Read a few messages back in the log if you got the time
19:18 tenplus1 checking
19:19 IhrFussel It's about my new pc...it arrived and seemed to work perfectly fine UNTIL I tried to load the desktop ... Btw it even has 8 GB RAM not 4
19:20 tenplus1 ooh, nice memory :)   trouble with monitor settings... what kinda monitor u got ?
19:20 IhrFussel TFT...so you think it is likely the monitor?
19:21 tenplus1 also if you have xubuntu desktop up and active, go into settings and windows advanced and turn compositing OFF
19:21 tenplus1 will stop flicker
19:22 IhrFussel It's not just the flicker...the whole X mode is corrupted I can only work with terminal (ctrl+alt+f1) AS SOON as I switch back to f7 the screen is corrupted again
19:23 tenplus1 damn, you using 14.04 ?
19:23 tenplus1 also what gfx card does your new system have ?
19:24 IhrFussel Yes still the stick with 14.04 and I go into "try before installing" mode ... If the GPU was damaged the text mode wouldn't work flawlessly...right?
19:25 tenplus1 depends... sometimes text modes will appear but anything graphical is an issue...  what gfx card do you have ?
19:25 IhrFussel It's just the integrated one...but is it normal that no driver is mentioned in lshw?
19:25 tenplus1 try lspci
19:26 IhrFussel One sec booting up again
19:31 IhrFussel WHAT?? It suddenly works now
19:32 tenplus1 w00t
19:32 IhrFussel Was the VGA cable too loose maybe?
19:32 tenplus1 could be loose connection on cable or card itself :)
19:32 tenplus1 you sitting on a new desktop ?
19:33 IhrFussel Here? On via Android...I really hope it is not some kind of "sometimes works other times not" issue xo
19:34 tenplus1 I would open desktop and reseat all cards to be sure :) and cabled
19:34 IhrFussel Loose cables can cause such corruptions in graphic mode?
19:34 tenplus1 oh yes
19:35 tenplus1 since it's working now I would update to 16.04 to get all the new drivers and kernel
19:36 IhrFussel First I need to install it to my 1 TB HDD now :D
19:36 tenplus1 ooh, good point :) ehe, thought it was already on desky
19:42 IhrFussel Even if you tell to NOT download updates when installing it still does x.x
19:43 tenplus1 it shouldnt...
19:43 tenplus1 but so long as it boots ok 1st time you can run update manager and move to 16.04.3 after
19:43 IhrFussel Well I didn't enable "download software"
19:44 IhrFussel Oh oh houston we have a problem...my stick has 32 bit xubuntu...
19:44 IhrFussel You can't update from 32 to 64 correct?
19:45 tenplus1 you COULD install that for now and downlaod the 64-bit .iso for the newer version and redo the flash drive
19:45 tenplus1 nope
19:45 tenplus1 upgrading from 32-bit to 64-bit is a lot of hassle and editing filed
19:45 IhrFussel 32 will still work like before with 64 bit CPU? Just slower?
19:45 tenplus1 it'll run fine :)
19:46 tenplus1 just not access all of the memory available, only 3.5gb limit
19:47 IhrFussel Ok^^ well the seller just told me this morning "oh and it's 8 gigs not 4" ... But he didn't up the price
19:47 Krock double the price
19:48 tenplus1 ehehe
19:48 tenplus1 install 14.04 32-bit as normal, boot into it and download 64-bit iso for new version and make a new flash drive to isntall from
19:49 Calinou what's the go-to creative server for nice builds?
19:49 IhrFussel Best software to make the live stick?
19:49 Calinou I need to take screenshots for minetest.net one day… :)
19:49 Calinou (with buildings, mods, possibly other players)
19:49 tenplus1 fussel, it comes with "USB Disc Creator" built in already
19:50 Calinou I'm not a good builder so I have nothing in singleplayer
19:50 IhrFussel So I just choose the iso and that's it? I need it tobe as simple as possible xP
19:51 tenplus1 https://xubuntu.org/getxubuntu/#lts
19:51 tenplus1 go there, download the .iso for the 64-bit xubuntu
19:51 tenplus1 and use USB Disc Creator to write it to your usb flash drive to make it bootable :) nice n easy
19:52 IhrFussel It saye64 bit AMD ... Mine isn't AMD o.o
19:53 tenplus1 that's ok
19:53 tenplus1 64-bit amd is fine :)))
19:53 tenplus1 it'll work perfectly on intel as well
19:53 IhrFussel Will work with pentium dou....sure?
19:53 tenplus1 yes, sure :)
19:53 tenplus1 I have an intel setup and use the 64-bit amd iso for install also
19:54 Donbatman the duo processor is 32 bit
19:54 Fixer disc or disk?
19:54 IhrFussel Donbatman I saw 64 bit
19:55 IhrFussel The CPU has lm flag which usually means 64
19:55 tenplus1 hi Don :)
19:55 Donbatman hi ten
19:55 tenplus1 do you have a spare flashd rive handy fussel ?
19:56 IhrFussel No I only have one...let me make sure that it's really 64
19:56 Calinou I think Core Duo is 64-bit, not sure
19:56 Calinou Core 2 Duo definitely is 64-bit
19:56 Donbatman if the processor is an intel duo then it is 32 bit. if it is dual core then it is 64
19:56 Calinou (don't use 32-bit when you can use 64-bit!)
19:56 Donbatman I have a duo and it is 32 bit
19:57 Donbatman the duo is a single core processor that kind of acts like a dual core
19:57 lisac joined #minetest-hub
19:57 tenplus1 hi lisac
19:57 Raven262 joined #minetest-hub
19:57 tenplus1 wb raven
19:57 Donbatman hi lisac
19:58 tenplus1 fussel, you can install HARDINFO and click on CPU to double check model.specs
19:58 Raven262 Odd, very very odd
19:58 Raven262 I mean my internet connection
19:58 tenplus1 ?
19:58 Raven262 I lost connection
19:59 Raven262 I thought it was my home installation
19:59 Raven262 well i have some cables lying around
19:59 Raven262 and they sometimes disconnect
19:59 Raven262 but it seems this wasn't it
20:00 IhrFussel Then I don't have a dou the exact name is Intel Pentium Dual-Core E5200
20:00 IhrFussel From 2009
20:00 Donbatman IhrFussel then use 64amd
20:00 tenplus1 yup, 64bit
20:00 Donbatman yup
20:01 Donbatman How have you been tenplus1?
20:01 tenplus1 good thanks, busy though... how's you ?
20:01 Donbatman Good
20:04 tenplus1 not seen you around for a while
20:04 Don_batman joined #minetest-hub
20:10 Don_batman joined #minetest-hub
20:10 IhrFussel Is there any way to see the GPU temp? I guess not with integrated chips
20:11 tenplus1 hardinfo is a tool for checking system info, if you click Sensors it may appear
20:11 tenplus1 failing that you can install psensor
20:16 IhrFussel Psensor works but only shows the temp of my cores
20:16 IhrFussel Should the graphoc chip have a similar temp as the CPU?
20:17 tenplus1 if it has a senson then it shoudl show up
20:17 IhrFussel Nope doesn't seem to have one...
20:17 tenplus1 but again you are using old version of xubuntu so you dont have newer drivers and support:P
20:18 IhrFussel Core 0 37°C
20:18 IhrFussel Core 1 39°C ... Ok in idle?
20:19 tenplus1 not bad
20:28 tenplus1 nite all :)
20:29 tenplus1 have fun with your new desktop fussel :P
20:29 tenplus1 left #minetest-hub
20:45 Fixer IhrFussel: not bad
20:46 Fixer IhrFussel: my Pentium 4 2.8 GHz was quite colder
20:46 IhrFussel Guys is it possible that a LAN cable could freeze the entire machine? Maybe it's a (very unlikely) coincidence but my PC suddenly had a freeze now TWICE while downloading
20:46 Fixer don't think so
20:47 IhrFussel Fixer, if it happens again I'll send a screenshot of what my screen looks like
20:48 IhrFussel Also any clue what the red lamp inside the tower means? It's on the entire time
20:49 Fixer power on?
20:49 IhrFussel When I shutdown it blinks for 1 minute
20:50 IhrFussel The power on light is green and at the front, the red one is somewhere in the middle
20:51 rubenwardy IhrFussel, no, but it could be a driver thing
20:51 rubenwardy also, *ethernet
20:51 IhrFussel Driver errors??
20:53 IhrFussel Also 3rd weird thing with this PC: After I power it off via the button it turns on again 5 secs later for 3 secs
20:54 IhrFussel Is that some kind of check?
20:55 Fixer Calinou: running Manjaro livecd in VM
20:55 Fixer IhrFussel: i hope you are not trolling
20:56 IhrFussel No I'm not trolling...the seller told me that's normal
20:56 Calinou Fixer: what for? testing?
20:56 Fixer Calinou: just to look
20:56 Calinou right
20:56 Fixer Calinou: also, AUR is impressive
20:57 Calinou I have Debian 9 and Fedora 25 VMs
20:57 Calinou yes, it is
20:57 Calinou (I need to upgrade to Fedora 26, by the way)
20:57 * Calinou starts up VirtualBox
20:57 Fixer it has even obscure stuff
20:57 Calinou yep
20:57 Calinou this is the upside of community-based things
20:58 Fixer visual-studio-code
20:58 Fixer kek
20:58 Calinou visual-studio-code-oss :D
20:58 Fixer 3rd in popularity on AUR
21:01 cx384 joined #minetest-hub
21:06 Fixer Krock: = no claims on this Y level is confusing
21:07 Krock so is the 4th dimension
21:10 Jordach Calinou, MS has been doing C/++ for nearly 4 decades, of course their IDE would be fantastic ;)
21:14 rubenwardy IntelliJ is better ;)
21:15 Jordach LUL
21:15 Jordach you mean the poor mans java IDE
21:15 Jordach Kappa
21:15 Calinou IntelliJ and derivatives are really nice
21:15 Calinou but none are actually open source, and most are paid
21:15 Calinou they also are Java-based, which means their font rendering isn't very good
21:16 Calinou however, if your language is supported, it remains the best IDE family…
21:16 Calinou (save for C++ on Windows: it doesn't support MSVC, only MinGW, currently)
21:16 Calinou (and has been doing so for 3 years already)
21:20 IhrFussel So are you telling me it's bad when the PC turns on for a few secs again after powering off via button?
21:21 Calinou that's weird, IhrFussel
21:21 Calinou never hard that issue on any PC of mine
21:23 IhrFussel It turns on, makes a click sound (guessing monitor) and turns off again 5 secs later BUT only when I shutdown AFTER the BIOS...if I turn off during BIOS it stays off
21:25 Calinou your PC is sentient! run!
21:27 paramat joined #minetest-hub
21:28 bigfoot547 joined #minetest-hub
21:49 IhrFussel Calinou, do you think that's critical or rather a (weird) setting?
21:51 Calinou I have no idea :(
22:00 Jordach IhrFussel, that click is possibly a PSU relay activating
22:00 Jordach my hifi makes a clunk on startup
22:00 IhrFussel Jordach, would that be bad or fine?
22:00 Jordach usually fine
22:00 Jordach sometimes very bad
22:01 IhrFussel Also I still cannot find anything regarding the red lamp in the center of my tower...I hope it doesn't indicate any failures
22:02 ThomasMonroe left #minetest-hub
22:12 Calinou lol, at every RES release, there's a "I clicked on the megaphone" meme: https://www.reddit.com/r/RESAnnounce​ments/comments/6nhsjp/announcement_r​es_v580_release_chrome_edge_firefox/
22:12 Calinou first one has 354 points
22:12 Calinou not bad
22:14 lisac joined #minetest-hub
22:21 Raven262 wb lisac
22:24 Shara There was a batman! And I missed him! :(
22:47 Megaf joined #minetest-hub
22:56 Megaf joined #minetest-hub

| Channels | #minetest-hub index | Today | | Google Search | Plaintext